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1 Guide to this manual

1.1 Introduction

This User Manual concerns the aggregation module, D-Waq DIDO, of the Delft3D software
suite. To make this manual more accessible we will briefly describe the contents of each
chapter and appendix.

If this is your first time working with D-Waq DIDO module we suggest you to read and practice
the getting started of Chapter 3 and the tutorial of Chapter 6. These chapters explain the user
interface options and guide you through the definition of your first aggregation.

Chapter 2: Introduction to D-Waq DIDO, provides specifications of D-Waq DIDO and the
areas of applications.

Chapter 3: Getting started, explains the use of the overall menu program, which gives
access to the Delft3D modules and to the pre- and post-processing tools. Last but not least
you will get a first introduction into the D-Waq DIDO Graphical User Interface, used to define
an aggregation of grid cells which can be used in a water quality simulation.

Chapter 4: General operation, provides practical information on the general operation of the
D-Waq DIDO module.

Chapter 5: Menu options, provides a description of all menu and toolbar options.

Chapter 6: Tutorial, emphasis at giving you some first hands-on experience in using the
D-Waq DIDO module to define the input of a simple problem and in executing a water quality
simulation.

References, provides a list of publications and related material on the D-Waq DIDO module.

Appendix A: Files of D-Waq DIDO, gives a description of the files that can be used in D-
Waq DIDO as input or output. Generally, these files are generated by D-Waq DIDO or other
modules of the Delft3D suite and you need not to be concerned about their internal details.
However, in certain cases it can be useful to know these details, for instance to generate them
by means of other utility programs.

1.2 Manual version and revisions

A manual applies to a certain release of the related numerical program. This manual applies
to D-Waq DIDO version 3.39.00.

1.3 Typographical conventions

Throughout this manual, the following conventions help you to distinguish between different
elements of text to help you learn about D-Waq DIDO.
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Example
Description

Module
Project

Title of a window or a sub-window are in given in bold.
Sub-windows are displayed in the Module window and
cannot be moved.
Windows can be moved independently from the Mod-
ule window, such as the Visualisation Area window.

Save Item from a menu, title of a push button or the name of
a user interface input field.
Upon selecting this item (click or in some cases double
click with the left mouse button on it) a related action
will be executed; in most cases it will result in displaying
some other (sub-)window.
In case of an input field you are supposed to enter input
data of the required format and in the required domain.

<\tutorial\wave\swan-curvi>
<siu.mdw>

Directory names, filenames, and path names are ex-
pressed between angle brackets, <>. For Linux en-
vironments a forward slash (/) is used instead of the
backward slash (\) for Windows environments.

“27 08 1999” Data to be typed by you into the input fields are dis-
played between double quotes.
Selections of menu items, option boxes etc. are de-
scribed as such: for instance ‘select Save and go to
the next window’.

delft3d-menu Commands to be typed by you are given in the font
Courier New, 10 points.

In this User manual, user actions are indicated with this
arrow.

[m s−1] [−] Units are given between square brackets when used
next to the formulae. Leaving them out might result
in misinterpretation. Most units will be in SI notation.
[m AD] stands for ’meter Above Datum’, which denotes
a level relative to the vertical reference system in the
model.

1.4 Changes with respect to previous versions

Version
Description

3.39 Complete new version of D-Waq DIDO
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2 Introduction to D-Waq DIDO

2.1 Introduction

Vergilius once wrote: "The Tyrian princess Dido succeeded the father and became queen of
Tyrus. Her brother Sichaeus had killed her husband, after which she fled via Cyprus to Africa.
There she asked a local king the favour to give her as much land as she could span with
the hide of a bull. When the king granted the request, she cut the hide into long, thin strips
enabling to span a much larger area. On this area Carthage was founded."

Feel yourself in the position of DIDO with the mouse and your computer screen, to fit the real
world to your needs.

2.2 Functional description

D-Waq DIDO is an interactive grid editor for coupling hydrodynamic models with the DELWAQ
model, Deltares (2024b). It uses a rectilinear, curvilinear or Finite Element hydrodynamic grid
layout as input. It produces the administration file needed by the Delft3D Water quality model
DELWAQ to condense the fine hydrodynamic grid to a coarser water quality grid. Each water
quality grid cell consists of one or more of the hydrodynamic grid cells. For Delft3D-FLOW
grids, using D-Waq DIDO without aggregation will produce a DELWAQ aggregation input for
the full hydrodynamic grid, although DELWAQ grid cells will be renumbered. This numbering
is the same as the numbering when using the (default) ’active only’ option in Delft3D-FLOW.

This means that D-Waq DIDO does NOT make grids, but modifies existing hydrodynamic grids
for use in water quality- and ecological modelling. D-Waq DIDO does so by defining a pointer
from each of the hydrodynamic grid cells to a water quality grid cell.

The resulting horizontal aggregation file (dwq-file), can be used in various ways. It can be
used directly in the hydrodynamic model, making the hydrodynamic model create aggregated
DELWAQ input. Or it can be used by a tool like AGRHYD that can aggregated unaggregated
DELWAQ input (??).

2.3 Implementation specific aspects

Although D-Waq DIDO can support a variety of hydrodynamic grid structures. Since this
manual is general, certain sections will refer to options that are masked(e. g. a regular ag-
gregation of every m x n grid cells is meaningless for irregularly linked grids and most finite
element grids).

For hydrodynamic computation using Delft3D-FM in parallel mode, the “Waqmerge” tool is
used to combine the multiply output files from D-Flow FM to one single domain D-Water
quality input files. Refer to the D-Water Quality Tools User Manual Deltares (2024a).
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3 Getting started

3.1 Overview of Delft3D

The Delft3D program suite is composed of a set of modules (components) each of which
covers a certain range of aspects of a research or engineering problem. Each module can be
executed independently or in combination with one or more other modules.

Delft3D is provided with a menu shell through which you can access the various modules. In
this chapter we will guide you through some of the input screens to get the look-and-feel of
the program. In the Tutorial, chapter 6, you will learn to define a simple scenario.

3.2 Starting Delft3D

To start Delft3D:

⋄ On an MS Windows platform: select Delft3D in the Programs menu.
⋄ On Linux machines: type delft3d-menu on the command line.

Next the title window of Delft3D is displayed, Figure 3.1.

Figure 3.1: Title window of Delft3D

After a short while the main window of the Delft3D-MENU appears, Figure 3.2.
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Figure 3.2: Main window Delft3D-MENU

Several menu options are shown. For now, only concentrate on exiting Delft3D-MENU, hence:

⋄ Click on the Exit push button.

The window will be closed and you are back in the Windows Desktop screen for PCs or on
the command line for Linux and UNIX workstations.

Remark:
⋄ In this and the following chapters several windows are shown to illustrate the presen-

tation of Delft3D-MENU and D-Waq DIDO. These windows are grabbed from the PC-
platform. For Linux workstation the content of the windows is the same, but the colours
may be different.

3.3 Getting into D-Waq DIDO

To continue start the menu program again as indicated above.

⋄ Click the Grid button.

Next the selection window for Grid and bathymetry is displayed for preparing a curvilinear
grid, interpolate data on that grid and aggregate the hydrodynamic cells, see Figure 3.3.
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Figure 3.3: Selection window for Grid and Bathymetry

Before continuing with any of the selections of this Grid and bathymetry window, you select
the directory in which you are going to prepare scenarios and execute computations.

⋄ Click the Select working directory button.

Next the Select working directory window is displayed, see Figure 3.4 (your current directory
may differ, depending on the location of your Delft3D installation).

Figure 3.4: Select working directory window

⋄ Browse to and open the <tutorial> sub-directory of your Delft3D Home-directory.
⋄ Open the <waq/dido> directory.
⋄ Enter the <friesian_tidal_inlet> sub-directory and close the Select working directory

window by clicking button OK, see Figure 3.5.

Deltares 7 of 87



DRAF
T

D-Waq DIDO, User Manual

Figure 3.5: Select working directory window to set the working directory to
<dido/friesian_tidal_inlet>

Next the Grid and bathymetry window is re-displayed, but now the changed current working
directory is displayed in the title bar, see Figure 3.6.

Figure 3.6: A part of the current working directory is shown in the title bar due to its length

Remark:
⋄ In case you want to start a new project for which no directory exists yet, you can select

in the Select working directory window to create a new folder.

⋄ Click on DIDO

D-Waq DIDO is loaded and the primary input screen is opened, Figure 3.7.
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Figure 3.7: Main window of the DIDO Graphical User Interface

In the lower-left corner of the status bar D-Waq DIDO gives additional operational information,
see Figure 3.8, such as:

⋄ User selections.
⋄ Operational instructions.
⋄ x and y co-ordinates of the current cursor position.
⋄ Co-ordinate system: Cartesian or Spherical.

Figure 3.8: Operational information displayed in the statusbar

The purpose of D-Waq DIDO is to create an aggregation file which can be used in the cou-
pling programs between a hydrodynamic simulation and D-Water Quality (i.e. Delft3D-FLOW,
SIMONA and TELEMAC).

3.4 Exiting D-Waq DIDO

To exit the D-Waq DIDO

⋄ Click Exit on the File menu.

You will be back in the Grid and bathymetry window, see Figure 3.3

⋄ Click Return to return to the main window of Delft3D-MENU, see Figure 3.2
⋄ Click Exit.

The window is closed and the control is returned to the desk top or the command line.

We encourage new users next to run the tutorial described in Chapter 6.
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4 General operation

4.1 General program operation instruction

Help

Upon selecting Help → User Manual, the RGFGRID User Manual in PDF-format will be
opened. Use the bookmarks in the contents to locate the subject you are interested in.

File menu

The file-menu is the standard Open and Save As window. The file mask depends on the type
of data that you want to open or save. You can change the directory by navigating through the
folders.

It is possible to specify whether to Stay on the Start-up Directory or not, in the Settings
General form.

General cursor and keyboard functions

The left mouse button activates or confirms desired actions. The Esc key cancels the last
edit action. The right mouse button may also confirm actions, or may put the program back
into its original mode.

4.1.1 Toolbars

The main window contains a men bar and two icon bars. The two icon bars are separated in
a main toolbar belonging to the overall handling and a toolbar belonging to specific handling
of the program RGFGRID.

4.1.1.1 Main toolbar

The main toolbar is shown in Figure 4.1.

Figure 4.1: Main toolbar

Print screen

Press Ctrl-P or click on the toolbar to obtain the print window for a hardcopy of the
current screen. This file is called <dido_date_time.pdf>

Zoom to extent

Click the icon to zoom to the full extent of the project area.

Zoom in

Click on the toolbar to zoom in, use the mouse wheel, or press Ctrl-+.
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Zoom out

Click on the toolbar to zoom out, use the mouse wheel, or press Ctrl-.

Zoom box

To define a zoom box, click on the toolbar and drag a box. If you define a zoom box from
right to left and from bottom to top then it will zoom out instead of zoom in.

Menu item to toolbar

When using the icon , the next chosen menu item will be placed in a separate toolbar.

As example, click the icon , and select from the menu File→Import→Grid (RGFGRID). . . .
An extra toolbar will appear with the chosen menu option, see Figure 4.2.

Figure 4.2: Menu item placed into extra toolbar

4.1.1.2 D-Waq DIDO toolbar

The program specific toolbar, see Figure 4.3, consists of icons which can also be reached via
menu options.

Figure 4.3: D-Waq DIDO specific toolbar

4.2 Toolbar

A list of all toolbar icons is given below:

Click this icon to centre the stereographic projection at the centre of the screen

Click this icon, move the mouse pointer to the reference point for which you want the
distance from, then press a or A to fix the anchor point

Click this icon to refresh the drawing.

If your project consists of multiple grids (so-called domain decomposition application) you

can switch between the grids by clicking on the toolbar. Next, click on the grid you
want to become the active grid.

Show or hide the legend.

Click this icon to start a new polygon (Area of influence or Cut out area as indicated in the
statusbar) or press N.

Click this icon to delete a polygon (Area of influence or Cut out area as indicated in the
statusbar) or press E. Click on one of the points of the polygon you want to delete.

Click this icon to insert a point into the polygon (Area of influence or Cut out area as
indicated in the statusbar) or press I. The point will be inserted at the closest linear piece
of the polygon.
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Click this icon to move a point on the polygon (Area of influence or Cut out area as indi-
cated in the statusbar) or press R.

Click this icon to delete a point on the polygon (Area of influence or Cut out area as
indicated in the statusbar) by indicating it or press D.

4.3 Key stroke functions

N = New
In the Edit → Polygon and Edit → Observation Areas options, pressing N allows you start
new polygons.

D = Delete
In the Edit → Polygon and Edit → Observation Areas options, pressing D allows you to
delete individual points using the mouse pointer.

E = Erase polygon
In Edit → Polygon, pressing E allows you to delete a polygon by clicking on one of its points
with the mouse cursor.

I = Insert
In Edit → Polygon or Edit → Observation Area, pressing I allows you to add new points to a
polygon using the mouse pointer.

R = Replace
In Edit → Polygon or Edit → Observation Area, pressing R allows you to replace (move)
individual points.

Ctrl-P = Print screen
Pressing Ctrl-P will open the print window. The current screen will be printed to your printer
or to a file.

Mouse wheel
Use the mouse wheel to zoom in and zoom out. Other ways are:

Ctrl + = Zoom in
Keep the Ctrl-key pressed and use the + key to zoom in more.

Ctrl - = Zoom out
Keep the Ctrl-key pressed and use the - key to zoom in more.

Ctrl move cursor = move focus of screen (panning)
Keep the Ctrl-key pressed and move the cursor around. The current screen will move
accordingly.

Ctrl arrow keys = move focus of screen left, right, up or down
Keep the Ctrl-key pressed and use the arrow keys to move the focus of the screen accord-
ingly.
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5 Menu options

The menu bar contains the following items, see Figure 5.1, each item is discussed in a sepa-
rate section

Figure 5.1: D-Waq DIDO menu options

5.1 File menu

Before opening an object (land boundary or polygon) be sure you choose the same co-
ordinate system as the grid file you want to edit.

Remark:
⋄ When opening files, D-Waq DIDO will not check the co-ordinate system in the files.

On the File menu, see Figure 5.2, options are available to import land boundaries, observation
areas, polygons, depth and grid files. The results at each stage of the aggregation process
can be saved.

Figure 5.2: Options on the File menu

The start-up directory to open and save files can be configured in the General Parameters
form on the menu Settings → General. As default the file menu starts at the last directory
selected.

For the formats of the files you are referred to Appendix A.

5.1.1 New project

Upon selecting File → New Project, all objects (land boundaries, polygons, grids, depths etc.)
will be deleted; i.e. you start from scratch.
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5.1.2 Open project

Upon selecting File → Open Project, the Open Project window appears in which you can
browse to an existing project (<∗.d3d> file).

Remark:
⋄ A project saved by RGFGRID or QUICKIN can be read by D-Waq DIDO

5.1.3 Save project

Upon selecting File → Save Project, the current project (filenames for hydrodynamic grid and
waterquality segments) will be saved under an overall project name. If the project name is not
known yet, the Save As Project window appears.

5.1.4 Save project as

Upon selecting File → Save Project As, the current project can be saved under a different
name.

5.1.5 Attribute Files

On the Attribute Files sub-menu, see Figure 5.3, options are available to open and save
objects that are indirectly related to the grids.

Figure 5.3: File → Attribute Files options

Open land boundary

Upon selecting File → Attribute Files → Open Land Boundary . . . , you can open a collection
of land boundaries. Land boundaries (or land-water marking) are in files with default mask
<∗.ldb>. It is in D-Waq DIDO only for display purposes.

Remark:
⋄ If you open another land boundary, it will be visualised together with an existing land

boundary.
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Open observation areas

Upon selecting File → Attribute Files → Open Observation Areas . . . , you can open a collec-
tion of observation areas with a file with default mask <∗.oai> (Observation Area Information
file). The polygons referenced in this file are per definition closed. If the polygon is not closed
in the file it will still be shown as closed.

Remark:
⋄ If you open another oai-file, then the previous one will be deleted

Open polygon

Upon selecting File → Attribute Files → Open Polygon . . . , you can open a collection of area
of interest polygons from a file with mask (<∗.pol>). Polygons are per definition closed. If
the polygon is not closed in the file it will still be shown as closed.

Remark:
⋄ If you open a second polygons file, it will be visualised together with existing polygons.

Save polygon

When saving polygons, each polygon will be saved as a closed polyline. A polygon file has
as default mask <∗.pol>.

Open Cut out

Upon selecting File → Attribute Files → Open Cut Out . . . , you can open a collection of cut
out polygons from a file with mask (<∗.pol>). You can also select a Cut Out Area Information
file (<∗.cai>) which will load the polygon, polyline and the dwq-file at once. When the file
<∗.cai> does not belong to the model area no files are loaded.

Figure 5.4: File → Attribute Files →Open Cut Out Area option when selecting the file
filter.

Remark:
⋄ If you open a second cut out file, it will be visualised together with existing cut out areas.

Save Cut out

When saving a cut out area a so called Cut out Area Information file will be saved, the default
extension is <∗.cai>. This file contains references to the defining polygon of the cut out area,
to the polylines of the open boundaries and the aggregation file. The open boundaries of the
cut out area does not reference to the existing open boundaries, even if those open boundaries
are part of the cut out area. The cut out polygon file has as default mask <∗.pol>, the cut
out open boundaries has a default mask <∗.pli> and the aggregation has a default mask
<∗.dwq>.
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5.1.6 Import

On the Import sub-menu, see Figure 5.5, options are available to import objects that are
directly related to the grids.

Figure 5.5: File → Import options

MDF-Flow (Delft3D)

When choosing the option File → Import → MDF-FLOW (Delft3D) . . . , you can open a collec-
tion of MDF-files from a Delft3D-FLOW hydrodynamic simulation. And all relevant information
for grid aggregation is loaded from the attributes files of these MDF-files. The following at-
tributes files will be read:

⋄ <∗.grd>, the grid file
⋄ <∗.enc>, the enclosure file,
⋄ <∗.bnd>, the open-boundary definition file,
⋄ <∗.dry>, the dry points definition file,
⋄ <∗.thd>, the thin dams definition file.
⋄ <∗.dep>, the depth definition file.

It is also possible to load these files separately, but this is not recommended! For a description
of the Open-boundary, dry points, thin dams and depth definition files, see section 5.1.8.
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WAQ Geom (D-Flow FM)

When choosing the option File →Import →WAQ Geom (D-Flow FM) . . . , you can open a
so called WAQ-Geom file, this is a file containing unstructured grid information. This file is
an output file of D-Flow FM hydrodynamic simulation, in case you have chosen to write the
waq-input files during the simulation.

Remark:
⋄ Also Delft3D-FLOW can write a WAQ-Geom file. The structured Delft3D-FLOW admin-

istration is than converted to the unstructured administration before the WAQ-Geom file
is written.

Grid (RGFGRID)

Upon selecting File → Import → Grid (RGFGRID) . . . , you can open a collection of grids.
The grid file has a default mask <∗.grd>, see section A.5.

Remarks:
⋄ The co-ordinate system in D-Waq DIDO is set accordingly to the system specified in

the grid file.
⋄ If the co-ordinate system is spherical then the co-ordinates are shown in stereographic

projection.
⋄ If no co-ordinate system is specified, Cartesian is presumed.

Grid Enc. (RGFGRID)

Upon selecting File → Import → Grid (RGFGRID) . . . , you can open the grid enclosure file
suitable for the active grid. The grid enclosure file is strongly related to the active grid due to
the grid indices definition in the file, see section A.6.

Grid (TELEMAC)

Upon selecting File → Import → Grid (TELEMAC) . . . , you can open a collection of grids
suitable for TELEMAC (triangle grid). The grid is in a file with default mask <∗.geo> or
<∗.slf>. The open boundary files with required mask <∗.cli>, are together read with the
grid if the basename of the file is the same.

Remark:
⋄ The open boundary file can not be read separately after the grid is read.

Aggregation

Upon selecting File → Import → Aggregation . . . , you can open one aggregation file suitable
for the active grid. The aggregation is in a file with default mask <∗.dwq>, see Appendix A.2.
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5.1.7 Export

On the Attribute Files sub-menu, see Figure 5.6, options are available to export objects that
are directly related to the grids.

Figure 5.6: File → Export options

Observation areas

Upon selecting File → Export → Observation Areas . . . , you can save the observation areas.

The data is stored in three separate files,

1 Observation Area Information file, containing general information about the observation
areas. The file has default mask <∗.oai>, see appendix A.10. Such as the names of the
areas and the reference to the polygon file with the actual polygons.

2 Polygons, these polygons indicate the observation area in world co-ordinates and is there-
for independent of the numerical model. The file has default mask <∗.pol>, see ap-
pendix A.4.

3 DMO, these file contains the segment numbers for each observations area and can be
used in the input file of D-Water Quality. The file has default mask <∗.dmo>, see ap-
pendix A.11.

When asked to save the polygon file, click Yes.

Aggregation

Upon selecting File → Export → Aggregation . . . , you can save the aggregation of the active
grid. The aggregation is stored in a file with default mask <∗.dwq>.

WAQ Geom (D-Flow FM)

Upon selecting File →Export →WAQ Geom (D-Flow FM) . . . , you can save the aggregated
WAQ-Geom file of the active grid. The aggregation is stored in a file with default mask
<∗_waqgeom.nc>.

20 of 87 Deltares



DRAF
T

Menu options

5.1.8 Flow attributes

Open-boundaries, DD-Boundaries, Dry points and Thin Dams definitions for the hydrody-
namic module Delft3D-FLOW or SIMONA need to be incorporated before generating the
aggregation, see Figure 5.7. The dry points are needed when generating the aggregation
because the dry points are not involved in the hydrodynamic computation and do not have
a cell/segment number. The Open and DD-boundaries are needed because the cells at the
boundary has their own numbering. See the SIMONA user manual (Rijkswaterstaat/RIKZ,
2007) how to define dry points for the hydrodynamic module SIMONA.

Figure 5.7: File → Flow Attributes options

Open Open-Boundaries (Delft3D )

Upon selecting File → Flow Attributes → Open Open-Boundaries (Delft3D) . . . , you can open
the open boundary file. Visualising the open boundaries can help you with the aggregation of
hydrodynamic cells. The open boundary is in a file with mask <∗.bnd>, see Appendix A.8.

Open DD-Boundaries (Delft3D)

Upon selecting File → Flow Attributes → Open DD-Boundaries (Delft3D) . . . , you can open
the domain decomposition boundary file. Visualising the DD-boundaries can help you with
the aggregation of hydrodynamic cells. The domain decomposition boundary is in a file with
mask <∗.ddb>, see Appendix A.12.

Open Dry Points (Delft3D)

Upon selecting File → Flow Attributes → Open Dry Points (Delft3D) . . . , you can open one
dry points file suitable for the active grid. The dry points are not counted in the segment
numbering, so loading dry points DIDO generates the ’Active Points Only’ segment numbers.

When opening a file with dry points and dry points are already defined, then the latter will be
removed, see Appendix A.13 for the file format.
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Open Thin Dams (Delft3D)

Upon selecting File → Flow Attributes → Open Thin Dams (Delft3D) . . . , you can open one
thin dams file suitable for the active grid. When a regular aggregation is applied, the aggre-
gated segments which would contain a thin dam are not aggregated. This option maintains
the geographical structure in the aggregated grid. Aggregations around thin dams have to
performed with the option of area of influence (Edit → Polygon) and regular aggregation or
manually (option Edit → Irregular )

When opening a file with thin dams and thin dams are already defined, then the latter will be
removed, see Appendix A.14 for the file format.

Open Depth (Delft3D)

Upon selecting File → Flow Attributes → Depth (Delft3D-FLOW) . . . , you can open one depth
file suitable for the active grid. The bathymetry can be used to influence the aggregation policy,
see section 5.5.1 item Aggregation below Z-level.

The bathymetry data is in the Delft3D-FLOW depth-file format with default mask <∗.dep>,
see Appendix A.7.

Open Dry Points (SIMONA)

Upon selecting File → Flow Attributes → Open Dry Points (SIMONA) . . . , you can open one
dry points file suitable for the active grid. The dry points are not counted in the segment
numbering, so loading dry points DIDO generates the ’Active points Only’ segment numbers.

When opening a file with dry points and dry points are already defined, then the latter will be
removed. The dry points data is in SIMONA format with default mask <dampoints∗>, see
the SIMONA User Manual Rijkswaterstaat/RIKZ (2007) for the file format..

5.1.9 Open Colour map

You can choose from a number of pre-defined colour schemes (in file with masks <∗.clr> or
<∗.clrmap>). These colour schemes have the same format as used for QUICKPLOT, see
Appendix A.15 for the file format.

Restriction:
⋄ Only the colour space RGB is supported

Remark:
⋄ If the file <dido.clrmap> exists on the start-up directory then this file will be read, if the

file does not exist on the start-up directory it will try to read the file on the installation
directory <$D3D_HOME/$ARCH/plugins/default>.
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5.1.10 Open Settings

If you have saved your D-Waq DIDO settings in a previous session, you can open these
settings again, see Appendix A.16 for the file format.

Remark:
⋄ If the file <dido.ini> exists on the start-up directory then this file will be read, if the

file does not exist on the start-up directory it will try to read the file on the installation
directory <$D3D_HOME/$ARCH/plugins/default>.

5.1.11 Save Settings

If you have made changes in one of the forms on the Settings menu, you can save these
settings to be used later on again.

5.1.12 Exit

Exit from the D-Waq DIDO program

5.2 Edit menu

On the Edit menu, see Figure 5.8, several edit modes can be selected

Figure 5.8: Options on the Edit menu

5.2.1 Aggregate

Upon selecting Edit → Aggregate, you can make a regular aggregation of the hydrodynamic
grid cells.

Regular grid

Click with the left mouse button in a grid cell of the hydrodynamic grid, then move the mouse
to an other grid cell. The grid cells which will be aggregated are indicated with a thick line.
Pressing the right mouse button will give a regular aggregation for the whole model. The
indicated area propagates through the entire grid.
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Irregular grid

Click with the left mouse button in a grid cell of the hydrodynamic grid and click than with the
right mouse button. The number of cells which will be aggregated is specified in the window
General Settings after choosing the menu option Settings →General settings. . . at ’Cells
to Aggregate’. At least the closest neighbouring grid cell is aggregated and the aggregation
propagates through the entire grid.

Remarks:
⋄ The operation can be limited by a polygon, this polygon defines an area of influence.

So the aggregation will only be performed for those cells whose cell centre are inside
the polygon. Cell centres are indicated by a dot.

⋄ A value of -1 for ’Cells to Aggregate’ will merge all cells together, which is useful in
combination with a polygon to merge a large cluster of cells.

⋄ The operation can be limited to areas with a certain depth. Below a specified z-level
the aggregation will be performed.

5.2.2 Manual

Upon selecting Edit → Manual, you can make an aggregation of the hydrodynamic volumes
controlled by clicking the hydrodynamic cells which need to be aggregated.

Click with the left mouse button in a grid cell of the hydrodynamic grid, then all the cells with
the same aggregation number are surrounded with a thicker line. To add a grid cell, to the
grid cells already indicated, click into another grid cell. Do this as much as needed. Finish the
operation by pressing the right mouse button.

5.2.3 Break up

Upon selecting Edit → Break Up, you can break up an aggregation.

Click into an area which is already aggregated to break up this aggregation, i.e. the default
aggregation is reset for this aggregated cell.

5.2.4 Selection polygon

The polygon is used to limit the area of influence of operations and/or edit actions, see Fig-
ure 5.9.
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Figure 5.9: Options on the Edit → Selection Polygon menu

5.2.4.1 Menu options

Edit

Upon selecting Edit → Selection Polygon → Edit, you can start editting a polygon that defines
a selection area. When there is no polygon the edit mode is set to New, otherwise you have
to select first a polygon (from the menu Edit → Selection Polygon → Select or press the key
s). After you have selected the polygon you can use key-strokes, icons in the toolbar or menu
items to switch the edit mode.

New

Upon selecting Edit → Selection Polygon → New, you can start to define a new polygon,

click on , or use the key-stroke n to start a new polygon.

Delete

Upon selecting Edit → Selection Polygon → Delete, click on , or use the key-stroke e, to
delete (erase) the selected polygon.

Select

Upon selecting Edit → Selection Polygon → Select, or use the key-stroke s, you can select a
polygon by clicking on one of its edges or vertices. AFter that the polygon will be highlighted
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Insert point

Upon selecting Edit → Selection Polygon → Insert Point, click on , or use the key-stroke
i, you can insert a point into the selected polygon.

In Edit →Selection Polygon, pressing I starts the vertex insert action depending on the first
click on the screen. If the first click is in between two vertices of the polygon then a point will
be inserted in the closest edge. The message at the left of the statusbar now reads ’Insert a
point’, click the left mouse to insert individual points.

Move point

Upon selecting Edit → Selection Polygon → Move Point, click on , or use the key-stroke
r, you can move (replace) a point on the selected polygon.

Delete point

Upon selecting Edit → Selection Polygon → Delete Point, click on , or use the key-stroke
d, you can delete a point on the selected polygon by indicating it.

5.2.4.2 Valid action keys are

The key stroke to reach the menu item Edit →Polygon →Edit is: CTRL+ALT+P

In Edit →Polygon mode the following keys can be used:

⋄ Key d: Delete
Pressing d allows you to delete individual polygon points by clicking on them using the
mouse cursor.

⋄ Key e : Erase polygon
Entire polygon sections are deleted. Press key e and then click with the left mouse button
on a point of the polygon which need to be deleted. Finish the operation by pressing the
right mouse button.

⋄ Key i: Insert
In Edit →Polygon, pressing I starts the vertex insert action depending on the first click on
the screen. If the first click is in between two vertices of the polygon then a point will be
inserted in the closest edge. The message at the left of the statusbar now reads ’Insert a
point’, click the left mouse to insert individual points.

⋄ Key n: New polygon
Pressing n allows you to start drawing a new polygon.

⋄ Key r: Replace
Pressing r allows you to replace (move) individual polygon points. The message at the
left of the statusbar now reads ’Replace: Get a Vertex’. If you have got it by clicking the
left mouse, the message will read ’Replace: Put a Vertex’, and you can do so by clicking
the left mouse at the new desired position.

⋄ Key x: Break open polygon
Keep X pressed and move with the cursor over a polygon point to split the polygon. Ef-
fectively, the pointed co-ordinates are replaced by default ‘missing’ values.
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5.2.5 Cut out area

The polygon is used to limit the hydrodynamic area for the Water Quality simulation, see
Figure 5.10.

Figure 5.10: Options on the Edit → Cut Out Area menu

5.2.5.1 Menu options

Edit

Upon selecting Edit → Cut Out Area → Edit, you can start editting a polygon that defines
an Cut Out Area. When there is no polygon the edit mode is set to New, otherwise you have
to select first a polygon (from the menu Edit → Cut Out Area → Select or press the key s).
After you have selected the polygon you can use key-strokes, icons in the toolbar or menu
items to switch the edit mode.

New

Upon selecting Edit → Cut Out Area → New, you can start to define a new polygon, click on

, or use the key-stroke n to start a new polygon.

Delete

Upon selecting Edit → Cut Out Area → Delete, click on , or use the key-stroke e to delete
(erase) the polygon.

Select

Upon selecting Edit → Cut Out Area → Select, or use the key-stroke s, you can select a
polygon by clicking on one of its edges or vertices. After that the polygon will be highlighted

Insert point

Upon selecting Edit → Cut Out Area → Insert Point, click on , or use the key-stroke i, you
can insert a point into the polygon.
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In Edit →Selection Polygon, pressing I starts the vertex insert action depending on the first
click on the screen. If the first click is in between two vertices of the polygon then a point will
be inserted in the closest edge. The message at the left of the statusbar now reads ’Insert a
point’, click the left mouse to insert individual points.

Move point

Upon selecting Edit → Cut Out Area → Move Point, click on , or use the key-stroke r, you
can move (replace) a point on the polygon.

Delete point

Upon selecting Edit → Cut Out Area → Delete Point, click on , or use the key-stroke d,
you can delete a point on the polygon by indicating it.

5.2.5.2 Valid action keys are

The key stroke to reach the menu item Edit →Cut Out Area →Edit is: CTRL+ALT+C

In Edit →Polygon mode the following keys can be used:

⋄ Key d: Delete
Pressing d allows you to delete individual polygon points.

⋄ Key e: Erase polygon
Entire polygon sections are deleted. Press key e and then click with the left mouse button
on a point of the polygon which need to be deleted. Finish the operation by pressing the
right mouse button.

⋄ Key i: Insert
In Edit →Polygon, pressing I starts the vertex insert action depending on the first click on
the screen. If the first click is in between two vertices of the polygon then a point will be
inserted in the closest edge. The message at the left of the statusbar now reads ’Insert a
point’, click the left mouse to insert individual points.

⋄ Key n: New Cut Out Area
Pressing n allows you to start drawing a new polygon.

⋄ Key r: Replace
Pressing r allows you to replace (move) individual polygon points. The message at the
left of the statusbar now reads ’Replace: Get a Vertex’. If you have got it by clicking the
left mouse, the message will read ’Replace: Put a Vertex’, and you can do so by clicking
the left mouse at the new desired position.

5.2.6 Observation area

Observation areas are collections of individual computational segments. The concentration,
computed by D-Water Quality, in each segment is averaged and the mass balances, if any,
are computed for the segments as a whole.

First you have to define the locations of observation areas by editing polygons, see Fig-
ure 5.11.
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Figure 5.11: Options on the Edit → Observation Area menu

For each area a polygon is required. When editing the polygon the default observation area
name is immediately given (’ObsArea ???’) and the segments which belong to this observa-
tion area are indicated by a thick line. When saving the observation areas the polygons and
segment numbers are saved in a separate file, see Section 5.1.7.

5.2.6.1 Menu options

Edit

Upon selecting Edit → Observation Area → Edit, you can start editting a polygon that defines
an Observation Area. When there is no polygon the edit mode is set to New, otherwise you
have to select first a polygon (from the menu Edit → Observation Area → Select or press
the key s). After you have selected the polygon you can use key-strokes, icons in the toolbar
or menu items to switch the edit mode.

New

Upon selecting Edit → Observation Area → New, click on , or use the key-stroke n, you
can sart to define a new observation area. Right mouse click to finish defining this polygon,
next click with left mouse button will start a new observation area.

Delete

Upon selecting Edit → Observation Area → Delete, click on , or use the key-stroke e, you
can delete (erase) a observation area by indicating it with the left mouse button.

Select

Upon selecting Edit → Observation Area → Select, or use the key-stroke s, you can select a
polygon by clicking on one of its edges or vertices. After that the polygon will be highlighted
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Edit name

Upon selecting Edit → Observation Area → Edit Name, you can change the observation area
name by indicating the area with the left mouse button. After this a form opens and you can
change the observation area name, see Figure 5.12.

Figure 5.12: Window Observation Area to change the observation area name

Insert point

Upon selecting Edit → Observation Area → Insert Point, click on , or use the key-stroke
i, you can insert a point into the polygon.

In Edit →Selection Polygon, pressing I starts the vertex insert action depending on the first
click on the screen. If the first click is in between two vertices of the polygon then a point will
be inserted in the closest edge. The message at the left of the statusbar now reads ’Insert a
point’, click the left mouse to insert individual points.

Move point

Upon selecting Edit → Observation Area → Move Point, click on , or use the key-stroke r,
you can move (replace) a point on the polygon.

Delete point

Upon selecting Edit → Observation Area → Delete Point, click on , or use the key-stroke
d, you can delete a point on the polygon by indicating it.

5.2.6.2 Valid action keys are

The key stroke to reach the menu item Edit →Polygon →Edit is: CTRL+ALT+P

In Edit →Polygon mode the following keys can be used:

⋄ Key d: Delete
Pressing d allows you to delete individual polygon points.

⋄ Key e : Erase polygon
Entire polygon sections are deleted. Press key e and then click with the left mouse button
on a point of the polygon which need to be deleted. Finish the operation by pressing the
right mouse button.

⋄ Key i: Insert
In Edit →Polygon, pressing I starts the vertex insert action depending on the first click on
the screen. If the first click is in between two vertices of the polygon then a point will be
inserted in the closest edge. The message at the left of the statusbar now reads ’Insert a
point’, click the left mouse to insert individual points.

⋄ Key n: New polygon
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Pressing n allows you to start drawing a new polygon.
⋄ Key r: Replace

Pressing r allows you to replace (move) individual polygon points. The message at the
left of the statusbar now reads ’Replace: Get a Vertex’. If you have got it by clicking the
left mouse, the message will read ’Replace: Put a Vertex’, and you can do so by clicking
the left mouse at the new desired position.

⋄ Key x: Break open polygon
Keep X pressed and move with the cursor over a polygon point to split the polygon. Ef-
fectively, the pointed co-ordinates are replaced by default ‘missing’ values.

5.3 Operations menu

On the Operations menu, see Figure 5.13, you may choose to change the centre of the
stereographic projection, remove the land boundary or generate a default aggregation.

Figure 5.13: Options on the Edit menu

5.3.1 Select domain

If your project consists of multiple grids (so-called domain decomposition application) you can

switch between the grids by clicking Edit → Select Domain, or click on the toolbar. Next,
click on the grid you want to become the active grid.

5.3.2 Delete domain

To delete a domain or grid, select Edit → Delete Domain. Next, click on an active or inactive
grid. When deleting a domain, also objects defined on that grid will be deleted.

5.3.3 Delete land boundary

All the points of the land boundary are removed.

5.3.4 Default aggregation

The default aggregation is no aggregation, so all water quality cells are equal to the hydrody-
namic cells. If a polygon is defined, the default aggregation is restricted to the inner area of
the polygon, i.e. the default aggregation is performed on those cells which have their centres
within the polygon.
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5.3.5 Start Regular Part

After selecting menu option Operations →Start Regular Part you have to select a structured
part of an unstructured mesh by clicking into the structured part. The unstructured grdi is
loaded by selecting File →Import →WAQ Geom (D-Flow FM). . . . The structured part is
now separated from the unstructured part, so normal regular aggregation actions can be
performed.

5.3.6 Finish Regular Part

After you did the regular aggregation on the chosen structured part of grid you have to finish
this action, explicitly.

5.4 View menu

On the View menu, you may choose to display several data sets; see Figure 5.14.

Figure 5.14: Options on the Edit menu

5.4.1 Spherical co-ordinates

Here you can select how to project the spherical co-ordinates onto the screen, see Fig-
ure 5.15.

Figure 5.15: Options on the View → Spherical Co-ordinates menu

Remarks:
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⋄ Only applicable for a spherical co-ordinate system.
⋄ Default: A spherical grid is shown in stereographic projected co-ordinates

Plane co-ordinates

Upon selecting View → Spherical Co-ordinates → Plane Co-ordinates, you can choose to
the display the co-ordinates as they are.

Stereo projected co-ordinates

Upon selecting View → Spherical Co-ordinates → Stereo Projected Co-ordinates, the co-
ordinates are displayed using a stereographic projection onto the screen.

5.4.2 Legend

Upon selecting View → Legend, you can show or hide the colour band on the left side of the
screen.

5.4.3 Grid information

Upon selecting View → Grid Information, you can point and click onto the grid to get some
characteristics cell numbers of the indicated cell, see Figure 5.17. The cell is also indicated
by a polygon.

Figure 5.16: Grid information

Node numbers

Upon selecting View → Grid Information → Node Numbers, you can show or hide the node
numbers of the hydrodynamic grid. If it is a regular (structured) grid, two indices will displayed
(m,n), if it is an irregular (unstructured) grid then just the number of the grid node will be
displayed.

WAQ cell numbers

Upon selecting View → Grid Information → WAQ Cell Numbers, you can show or hide the
cell numbers of the water quality grid. For a regular (structured) as well as a irregular (un-
structured) grid the cell number will be displayed.
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Default cell numbers

Upon selecting View → Grid Information → Default Cell Numbers, you can show or hide the
cell numbers for a defaut aggregation, i.e. no aggregation. For a regular (structured) as well
as a irregular (unstructured) grid the cell number will be displayed.

Grid cell indices

Upon selecting View → Grid Information → Grid Cell Indices, you can show or hide the index
numbers of the regular (structured) hydrodynamic grid, two indices will displayed (m,n).

Select cell

Upon selecting View → Grid Information → Select Cell. . . , you can retrieve some cell admin-
istration. After selecting a cell these information will be showed in the Cell Administration
window, see Figure 5.17.

Figure 5.17: Grid information

5.4.4 Find grid cell

Upon selecting View → Find Grid Cell. . . , you can find the hydrodynamic or water quality grid
cell. To find the hydrodynamic grid cell type in its number and set the water quality grid cell
to zero. To find the water quality grid cell type a zero for the hydrodynamic grid cell and the
a cell number for the water quality The last search will indicate more than one cell if the grid
was aggregated.

Figure 5.18: Give cell number menu
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5.4.5 Check partition

Upon selecting View → Check Partition, you can check if the observation areas do partition
the whole computational area. This functionality can be useful to generate some data fields
which need to cover the whole area.

Cells can not be inside more than one observation area, see Figure 5.19. The cells are
coloured accordingly

Green: The cell centre is in just one observation area.
Red: The cell centre is in more than one observation area.
Blue: The cell centre is outside any observation area.

Figure 5.19: Check partition

5.4.6 Land boundary

Upon selecting View → Land Boundary, you can show or hide the land boundary. The land
boundary is drawn as a polyline.

5.4.7 Observation areas

Upon selecting View → Observation Areas, you can show or hide the observation areas.

5.4.8 Water Quality grid

Upon selecting View → Water Quality Grid, you can show or hide the water quality grid. The
water quality grid is drawn above the hydrodynamic grid.

5.4.9 Hydrodynamic grid

Upon selecting View → Hydrodynamic Grid, you can show or hide the hydrodynamic. The
hydrodynamic grid is drawn below the water quality grid.

5.4.10 Boundary

Upon selecting View → Boundary, you can show or hide the open boundaries.

Deltares 35 of 87



DRAF
T

D-Waq DIDO, User Manual

5.4.11 Depth

Upon selecting View → Depth, you can show or hide the depth values. The depth is located
at the cell corners of the hydrodynamic grid.

5.4.12 Dry points

Upon selecting View → Dry Points, you can show or hide the dry points. The dry point is
located at a cell of the hydrodynamic grid.

5.4.13 Thin dams

Upon selecting View → Thin Dams, you can show or hide the thin dams. The thin dam is
located at the cell faces of the hydrodynamic grid.

5.5 Settings menu

The following options can be accessed through the Settings menu, see Figure 5.20

Figure 5.20: Options on Settings menu

5.5.1 General

When clicking on the Settings → General menu, a form opens in which you can select some
general parameters; see Figure 5.21

⋄ Stay on Startup directory default: 0 (Off)
When navigating through the directories in the file selecting window, you can specify
whether to always go back to the start up directory (1), or keep the latest directory (0).

⋄ Cells to Aggregate default: 2
Maximum number of volumes which can be aggregated to one water quality volume for
an unstructured grid for hydrodynamics. TELEMAC allows the values 1, 2 and 3. Other
unstructured grids also allow a value of 4. A value of -1 will merge all cells together, which
is useful in combination with a polygon to merge a large cluster of cells.

⋄ Aggregation below Z-level default: ∞
The aggregation will be performed where the depth is deeper then the given reference
level, for the shallower parts of your model no aggregation will be performed.
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Figure 5.21: Options on Settings → General menu

5.5.2 Change colour map

When clicking on the Settings → Change Colour Map menu, a form opens in which you
can select the relation between a parameter (i.e. Depth) and the loaded colour maps, see
Figure 5.22

Figure 5.22: Options on Settings → Colours menu

5.5.3 Legend

When clicking on the Settings → Legend menu, a form opens in which you can define how
the iso-colour figures should be displayed; see Figure 5.23

Figure 5.23: Options on Settings → Legend menu

⋄ Autoscale Legend default: On
Specify whether the program should determine the isocolour values automatically, or to
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do it yourself. If you leave it to the program, it will determine the minimum and maximum
depth value within the viewing area and display the number of iso-colours specified above.
Zooming in will always result in display of the same number of iso-colours. If you want to
specify the isocolour values yourself, you have to specify one of the three parameters
below. When zooming in, the iso-colour values will remain fixed.

⋄ Minimum Value
Specifying this value turns autoscale off.

⋄ Maximum Value
Specifying this value turns autoscale off.

⋄ Classes default: 20
The number of classes can be specified

⋄ X Co-ordinate Legend default: 16
X Co-ordinate of lower left corner of legend in pixels

⋄ Y Co-ordinate Legend default: 20
Y Co-ordinate of lower left corner of legend in pixels

5.5.4 Colours

When clicking on the Settings → Colours menu, a form opens in which you can define the
colours for background, land boundary, polygons, etc.; see Figure 5.24
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Figure 5.24: Options on Settings → Colours menu

5.5.5 Sizes

When clicking on the Settings → Sizes menu, a form opens in which you can define the
linewidth and dotsize in pixels. See Figure 5.25
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Figure 5.25: Options on Settings → Sizes menu

5.5.6 Order caches

The parameters set in the Order caches window, see Figure 5.26, influence the drawing order
of the several items. The drawing order of the caches is: 5, 4, 3, 2, 1, 0. Cache 5 is drawn
first and cache 0 is drawn last. So the items which will drawn in cache 0 are drawn on top. If
there is no need to draw a cache it will not be done, this improves the drawing performance
by avoiding unnecessary drawings. Therefore, if an item is changed in cache 3 only caches
3, 2, 1 and 0 are drawn.
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Figure 5.26: Options on Order Caches window

⋄ Inactive Depth default: 5
⋄ Active Depth default: 5
⋄ Centres default: 5
⋄ Inactive Grid default: 4
⋄ Active Grid default: 4
⋄ Inactive Volumes default: 3
⋄ Active Volumes default: 2
⋄ Boundaries default: 1
⋄ Land Boundary default: 1
⋄ Obs. Areas default: 2
⋄ Drypoints, Thin Dams, Observation Points default: 1
⋄ Samples default: 1

5.5.7 Change centre of projection

For spherical co-ordinates D-Waq DIDO can use two different projections, no projection and
stereographic projection. For stereographic projection a special function is implemented to
centring the computer screen to the centre of projection and the sphere. This function can
be invoked by clicking the menu item Operations → Change Centre of Projection see Fig-
ure 5.13. When using this command the centre of the projection is set to the centre of the
screen. This action requires recalculation of the projection and a new screen refresh. The
centre of the projection does not change when using zoom in, zoom out or pan, so there is no
performance drawback and a smooth screen-refresh is obtained.
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5.6 Help menu

On the Help menu, you may choose to read the user manual or the version number of D-Waq
DIDO; see Figure 5.27

Figure 5.27: Options on Help menu

5.6.1 User manual

When clicking on the Help →User Manual the user manual of D-Waq DIDO will be displayed
(<D-Waq DIDO _User_manual.pdf>), see Figure 5.28.

5.6.2 About

When clicking on the Help →About a window will display the current version number of D-Waq
DIDO.

Figure 5.29: About box
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Figure 5.28: Front page of the manual
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6 Tutorial

6.1 Delft3D structured grid

In this tutorial some functionality of D-Waq DIDO will be demonstrated. On the basis of the
"Friesian Tidal Inlet" example a D-Waq DIDO session is explained. In advance, both the
starting situation and the final situation are shown below in Figure 6.1.

This tutorial describes in detail how to proceed from the starting situation towards the final
situation.

(a) Not aggregated, start situation (b) Aggregated, final situation

Figure 6.1: Start and final situation of the clarified D-Waq DIDO session

Before you can start with the tutorial you have to start Delft3D and set the working directory
to the tutorial model located on <%D3D_HOME%/tutorial/waq/dido/friesian_tidal_inlet>.

6.1.1 Loading the model

Open the grid and land boundary file. The grid file is the grid which will be use by the hydro-
dynamic program, Deltares (2024c). The land boundary file is just for orientation purposes.

⋄ On the File menu, point to Import and click on Grid (RGFGRID)
⋄ Select and Open the <friesian_tidal_inlet.grd>

⋄ On the File menu, point to Attributes Files and click on Open Land Boundary
⋄ Select and Open the <netherlands.ldb>

Now the grid and land boundary are visualised in the D-Waq DIDO window, see Figure 6.2.
Although the land boundary has a greater extent the extent of the window is unchanged. The
first opened file determines the extent of the main window.
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Figure 6.2: Hydrodynamic grid

6.1.2 Zoom out and zoom in

Zooming out the model in discrete steps

⋄ Click on .

To zoom out to the full extent of all loaded files

⋄ Click on .

Now you have a picture where you can see the whole Dutch coast, and as you can see
Friesian Tidal Inlet model is in the north of The Netherlands.

To zoom in on the grid there are several possibilities

⋄ Use the mouse scroll wheel. The cursor is the fix point when scrolling the mouse wheel.

⋄ Click on and drag a rectangle. Do it several times after each other and terminate the
zoom in action by pressing the right mouse button.

⋄ Click on .

To pane the grid: keep the CTRL-key down and move around with the cursor.

6.1.3 Two by two aggregation

The grid and land boundary are loaded and the next step will the hydrodynamic grid to two by
two cells aggregation which will be used by the water quality grids.

Choose the menu-option Edit → Aggregate, you can click the two corner cells which form the
outline of the new aggregated cell.

⋄ Click on the first cell (see Figure 6.3)
⋄ Move the mouse to the opposite corner
⋄ Click on the right mouse button to obtain the aggregation for the whole area, Figure 6.4
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Figure 6.3: Selected corner for the two by two aggregation

Figure 6.4: Result of a two by two aggregation

6.1.4 Default aggregation in inlet

The whole model has now a aggregation of two by two grid cells. But in the entrance of the
tidal inlet we do not need an aggregation of the hydrodynamic grid. There are several options
to reach this situation.

1 use the break up option
2 define an area of influence and define a new aggregation with that area

6.1.5 Break up the aggregated cells

Choose the menu-option Edit → Break Up, you can click into an aggregated cell to obtain the
default aggregation for that cell. Continue with clicking into the several aggregated grid cells
to get the result aggregation as shown in Figure 6.1 In this way you have fully control to break
up the aggregation for each cell.

6.1.6 Define area of influence

An other way to obtain the final aggregation as shown in Figure 6.1 is to define an area of
influence. An area of influence is that area to which the operation is restricted and is defined
by a polygon. So we start with defining a polygon.

Deltares 47 of 87



DRAF
T

D-Waq DIDO, User Manual

Choose the menu-option Edit → Polygon → New or click on the toolbar icon and next
clicking the left mouse button to define the polygon to get Figure 6.5

Figure 6.5: Area of influence defined by the polygon

Choose now the menu-option Operation → Default Aggregation and within the polygon all
aggregated cells have the default aggregation, i.e. the water quality cells are equal to the
hydrodynamic cells.

6.1.7 Saving the result

Before you end your D-Waq DIDO session you have to save the results from the aggregation.
The aggregation can be saved to file.

Choose the menu option File → Export → Aggregation. and the Save Aggregation window
will be opened (Figure 6.6).

Figure 6.6: Save Aggregation window

Or choose the menu option File → Save Project As and the Save Project window will be
opened (Figure 6.7). After saving the project file (<∗.d3d>) the window Save Aggregation
to save the aggregation file <∗.dwq> will appear (Figure 6.8).
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Figure 6.7: Save Project window, saving Friesian Tidal Inlet project

Figure 6.8: Save Aggregation window, saving the Friesian Tidal Inlet aggregation

The advantage to save the aggregation in a <∗.d3d> file is that the reference to all the grids
and their aggregation are saved, especially for multi domain models this is an advantage.
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6.2 D-Flow FM structured/unstructured grids

D-Waq DIDO can also be used with D-Flow FM grids, the D-Flow FM grids support several
kinds of element shapes (triangles, quads, pentagons and hexagons). For examples of these
element shapes, see Figure 6.9.

Figure 6.9: Example of supported element shapes by D-Flow FM (with thindams).

Depth dependent aggregation

This tutorial describes in detail how to proceed from the start situation towards the final situa-
tion. In Figure 6.10 are the start (Figure 6.10a) and final (Figure 6.10b) situation shown.

(a) Not aggregated, start situation. (b) Aggregated, final situation.

Figure 6.10: Start and final situation of this D-Waq DIDO tutorial.

Before you can start with the tutorial you have to start Delft3D and set the working directory
to the tutorial model located on <%D3D_HOME%/tutorial/waq/dido/westernscheldt>.

6.2.1 Loading the model

Open the grid and land boundary file. The grid file contains the grid which is used by the
hydrodynamic program D-Flow FM. The land boundary file is just for orientation purposes.

On the File menu, point to Import and click on Grid (D-Flow FM)
Select and Open the <westerschelde_su_net.nc>

On the File menu, point to Attributes Files and click on Open Land Boundary
Select and Open the <zeeland.ldb>
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Now the grid and land boundary are visualised in the D-Waq DIDO window, see Figure 6.11.
Although the land boundary has a greater extent the extent of the window is unchanged. The
first opened file determines the extent of the main window.

Figure 6.11: Initial aggregation is equal to hydrodynamic grid

6.2.2 Aggregation on unstructured grid

First we do an irregular aggregation on the whole grid. By defining a polygon the influence
area of any operation can be restricted to the area enclosed by the polygon. No polygon is
needed in this tutorial.

Because we describe a depth dependent aggregation we have to set the z-level where the
aggregation is performed beneath. In this tutorial we set the level to -9 [m], Figure 6.12.

Select from the menubar Settings→General. . . and specify for Aggregation below z-Level
the value “-9”.
Click OK.

Figure 6.12: Window General Parameters

Now the z-level is specified, we continue with the aggregation.

Select from the menubar Edit →Aggregate.
Click somewhere in the grid with the left mouse button and press the right mouse button
to activate the aggregation.

The result is shown in Figure 6.13. As you can see the aggregation is also performed over the
structured part of the grid. Also can be seen that not all grid elements are aggregated, those
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elements has an averaged bed level above the specified z-level for aggregation (here -9 [m]).
How to zoom-in and zoom-out is described in section 6.1.2.

Figure 6.13: Irregular aggregation (after zooming in).

6.2.3 Structured two by two aggregation

To do a structured aggregation for the structured part of the grid you have to select this part
first.

Select from the menubar Operations →Start Regular Part, see Figure 6.14.

Figure 6.14: Select regular grid part.

After this selection the unstructured hydrodynamic grid is shown without aggregation, in this
way the structured part of the grid is easily recognized, see Figure 6.15.
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Figure 6.15: After selecting the menu option Operations →Start Regular Part, but just
before selecting the regular part by a left mouse click.

Click with the left mouse button on the structured part of the grid.

Now the structured part of the grid is shown including the irregular aggregation which was
already performed, Figure 6.16. Selecting a structured part of an unstructured grid is depen-
dent on which element is pointed by the mouse click. In this tutorial it is a simple structured
part, so there is no dependency on the location of the mouse click, but in ore elaborating grids
it could depend on the location. This selection does not care of any specified polygon.

Figure 6.16: Regular part selected, including the irregular aggregation.

See section 6.1.3 how to aggregate on a structured grid.

Do a 2x2 regular aggregation on the selected part of the grid.

The result is shown in Figure 6.17.
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Figure 6.17: 2x2 aggregation performed.

In Figure 6.17 the previous aggregation is also shown. Showing the previous aggregation
has the advantage to see what the aggregation was on the unstructured part of the grid. To
finish the structured aggregation and merge the aggregation into the unstructured you have
to perform the next action.

Select from the menubar Operations →Finish Regular Part, see Figure 6.18

Figure 6.18: Select Finish Regular Part.

The final result is shown in Figure 6.19, and has a structured aggregation on the structured
part of grid and unstructured aggregation on the unstructured part of the grid
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Figure 6.19: Example of depth dependent aggregation.

6.2.4 Saving the result

Before you end your D-Waq DIDO session you have to save the results from the aggregation.

Choose the menu option File → Export → Aggregation and save the aggregation to file.

6.3 TELEMAC finite element grid

TELEMAC users can also use D-Waq DIDO to aggregate the water quality grid cells. TELEMAC
is an hydrodynamic program which uses unstructured collocated triangular grids (see Fig-
ure 6.20).

Before you can start with this tutorial you have to start Delft3D and set the working directory to
the tutorial model located on <%D3D_HOME%/tutorial/waq/dido/bridge_in_river> and load
the file <bridge_2_pillars.geo>, File →Import →Grid (Telemac)

Figure 6.20: TELEMAC hydrodynamic triangular grid

Due to the collocation of the variables in TELEMAC and the need of finite volumes in the water
quality program D-Water Quality, see Deltares (2024b), the hydrodynamic grid and the water
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quality grid are different, as seen by comparison of the Figures 6.20 and 6.21

Figure 6.21: Finite Volume grid, based on a triangular collocated hydrodynamic grid

The aggregation of water quality cells is not as straightforward as for structured grids with
staggered variables used in Delft3D-FLOW. For Delft3D-FLOW and D-Water Quality the hy-
drodynamic grid and the default water quality grid is the same. For unstructured grids we
allow two different options of aggregation

1 Default aggregation
2 Aggregate at most three cells together

The default aggregation means that all finite volumes around the hydrodynamic grid nodes(indicated
by a dot in the figures) are disjunct.

For a three cell aggregation choose menu-option Settings → General and set Cells to Ag-
gregate to “3”, continue with Edit → Aggregate, you can click the intersection point of three
different volumes to aggregate this cells. These three cells will be the starting point of the al-
gorithm to aggregate as much as possible three hydrodynamic cells to one water quality cell.
Due to the irregularity of the grid you will see that some water quality cells are not aggregated
and others are just aggregated to their neighbour.

⋄ Click on intersection point
⋄ Click on the right mouse button to obtain the aggregation for the whole area, Figure 6.22
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Figure 6.22: Aggregated Finite Volume grid

All other options of D-Waq DIDO can also be used in combination with a TELEMAC grid.
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In the following sections we describe the attribute files used in D-Waq DIDO.

For each file which can handled by D-Waq DIDO we give the following information:

⋄ File contents.
⋄ Filetype (free formatted, fix formatted or unformatted).
⋄ Filename and extension.
⋄ Generated by (i.e. how to generate the file).
⋄ Restrictions on the file contents.
⋄ Example(s).

Remarks:
⋄ The access mode of all attribute files is sequential.
⋄ In the examples the file content is printed in font Courier and comment (not included in

the file) between curly brackets font, unless explicitly stated differently.

A.1 Delft3D project file
File contents Domain input for a model.
Filetype ASCII
File format Free formatted.
Filename <name.d3d>
Generated RGFGRID, QUICKIN, D-Waq DIDO, or manually offline

Record description:

A header block containing general information and then for each domain a detailed descrip-
tion.

Keyword Description

FileInformation

FileCreatedBy Version string of the program who generated this file the first time

FileCreationDate Creation date and time

FileVersion Version number of <∗.d3d> file

Geometry

LandBoundaryName Name of the file with the land boundaries

LandBoundaryFormat Format of the land boundary file, possible values are: TEKAL,
NETCDF or SHAPEFILE. The NetCDF file is according the ’World
Vector Shoreline’ format

DDBound

FileDDBound Name of the file with the domain decomposition boundaries
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For each grid

Keyword Description

Grid

Type Format of the grid file, possible values are: RGF, RGF_NETCDF,
DFLOW_FM, TELEMAC

FileName Name of grid file with the geographical co-ordinates

FlowDepth Name of the file containing the depth values at the cell corners of
the grid

Aggregation Name of the aggregation file

Restriction:
⋄ The maximum record length in the file is 132.

Example:

The model friesian_tidal_inlet contains three different subdomains (f01, f02, f03) and the
project file has the name <friesian_tidal_inlet.d3d.>

[FileInformation]
FileGeneratedBy = Deltares, Delft3D-DIDO Version 4.04.00.11836M, Jun 21 2010, 12:09:34
FileCreationDate = 2010-06-21, 13:35:22
FileVersion = 0.03

[DDBound]
FileDDBound = f34-123.ddb

[Grid]
Type = RGF
FileName = f01.grd
Aggregation = f34_dd-f01.dwq
Monitoring Areas = f34_dd-f01.dmo

[Grid]
Type = RGF
FileName = f02.grd
Aggregation = f34_dd-f02.dwq
Monitoring Areas = f34_dd-f02.dmo

[Grid]
Type = RGF
FileName = f03.grd
Aggregation = f34_dd-f03.dwq
Monitoring Areas = f34_dd-f03.dmo
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A.2 Aggregation file
File contents The aggregation table of hydrodynamic volumes
Filetype ASCII
File format Free formatted
Filename <name.dwq>
Generated D-Waq DIDO

Record description:

Record Record description

1 five integer numbers separated by a blank.
nmax number of computational volumes in η-direction
mmax number of computational volumes in ξ-direction
mmax∗nmax total number of computational volumes
xxx
xxx

2–end one integer containing the aggregation volume index number

Restriction:
⋄ The input items are separated by one or more blanks

Example:

Model area with 8 ∗ 6 volumes (free formatted file).

6 8 48 1 0
0
0
0
0
0
0
0
1
1
4
4
0
0
1
1
4
4
0
0
2
2
5
5
0
0
2
2
5
5
0
.
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.

.

Remark:
⋄ Number of records is equal to mmax ∗ nmax+ 1

A.3 Land boundary file
File contents The co-ordinates of one or more polylines. Each polyline (piecewise

linear) is written in a single block of data.
Filetype ASCII
File format Free formatted
Filename <name.ldb>
Generated RGFGRID, QUICKIN, etc

Record description:

Record Record description

Preceding description records, starting with an asterisk (∗), and will
be ignored.

1 A non blank character string, starting in column one

2 Two integers representing the numbers of rows and number of
columns for this block of data

Two reals representing the x, y or λ, ϕ-co-ordinate

Example:

*
* Polyline L007

*
L007
6 2

132400.0 549045.0
132345.0 549030.0
132165.0 549285.0
131940.0 549550.0
131820.0 549670.0
131585.0 549520.0

*
* Polyline L008

*
L008
4 2

131595.0 549685.0
131750.0 549865.0
131595.0 550025.0
131415.0 550175.0

*
* Polyline L009

*
L009
6 2

131595.0 549655.0
148975.0 564595.0
150000.0 564935.0

64 of 87 Deltares



DR
AF
T

Files of D-Waq DIDO

152105.0 565500.0
153150.0 566375.0
154565.0 567735.0

Remark:
⋄ In case this file is read as a polygon file then the polylines are closed by D-Waq DIDO

to get a polygon.

A.4 Polygon file
File contents The co-ordinates of one or more polygons. Each polygon is written

in a single block of data
Filetype ASCII
File format Free formatted
Filename <name.pol>
Generated RGFGRID, QUICKIN, D-Waq DIDO, etc

Record description:

The file may contain one or more polygons. For every polygon the file should contain a line
indicating the name of the polygon, followed by a line indicating the number of points making
up the polygon and the number of coordinates, i.e. 2, finally followed by the coordinate data.

Record Record description

Preceding description records, starting with an asterisk (∗), and will
be ignored.

1 A non blank character string, starting in column one

2 Two integers representing the numbers of rows and number of
columns for this block of data

Two reals representing the x, y or λ, ϕ-coordinate

Restriction:
⋄ The first record and the last record in the block should be the same

Example:

*
* Deltares, Delft3D-DIDO Version 3.39.01.4423:4459, Sep 25 2008, 20:10:54

* 2008-09-25, 22:11:08

*
Observation Area 001

5 2
1.8768018E+05 6.1708738E+05
1.8996981E+05 6.1001035E+05
1.9746314E+05 6.1266423E+05
1.9480925E+05 6.1838830E+05
1.8768018E+05 6.1708738E+05

Observation Area 002
5 2

2.0011703E+05 6.1818015E+05
1.9819166E+05 6.1063479E+05
2.0568498E+05 6.0870942E+05
2.0797461E+05 6.1599460E+05
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2.0011703E+05 6.1818015E+05
Observation Area 003

5 2
1.9340425E+05 6.1396516E+05
2.0183425E+05 6.1365294E+05
1.9944054E+05 6.0558720E+05
1.9522555E+05 6.0595146E+05
1.9340425E+05 6.1396516E+05

A.5 Orthogonal curvilinear grid file
File contents The co-ordinates of the orthogonal curvilinear grid at the depth points.
Filetype ASCII
File format Free formatted
Filename <name.grd>
Generated RGFGRID

Record description:

Record Record description

Preceding description records, starting with an asterisk (∗), will be
ignored.

1 Record with Co-ordinate System = Cartesian or value
Spherical

2 Record with
Missing Value = -9.99999000000000024E+02.
If this record is not given 0.0 will be assumed as missing value.

3 The number of grid points in m- and n-direction (2 integers).

4 Three real values (not used).

5 to K+5 A label and record number, the x-component of the world co-
ordinates of all points in m-direction, starting with row 1 to row
nmax, with as many continuation records as required by mmax
and the number of co-ordinates per record. The label and record
number are suppressed on the continuation lines. This set of records
is repeated for each row until n = nmax.

K+5 to 2K+4 A similar set of records for the y-component of the world co-
ordinates.

K is the number of records to specify for all grid points a set of x- and y-co-ordinates.

Restrictions:
⋄ The grid must be orthogonal.
⋄ Input items in a record are separated by one or more blanks.

Example:

*
* Deltares, Delft3D-RGFGRID Version 4.16.01.4531, Sep 30 2008, 23:32:27

* File creation date: 2008-10-01, 23:19:22

*
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Coordinate System = Cartesian
9 7

0 0 0
Eta= 1 0.00000000000000000E+00 1.00000000000000000E+02 2.000000...

5.00000000000000000E+02 6.00000000000000000E+02 7.000000...
Eta= 2 0.00000000000000000E+00 1.00000000000000000E+02 2.000000...

5.00000000000000000E+02 6.00000000000000000E+02 7.000000...
Eta= 3 0.00000000000000000E+00 1.00000000000000000E+02 2.000000...

5.00000000000000000E+02 6.00000000000000000E+02 7.000000...
Eta= 4 0.00000000000000000E+00 1.00000000000000000E+02 2.000000...

5.00000000000000000E+02 6.00000000000000000E+02 7.000000...
Eta= 5 0.00000000000000000E+00 1.00000000000000000E+02 2.000000...

5.00000000000000000E+02 6.00000000000000000E+02 7.000000...
Eta= 6 0.00000000000000000E+00 1.00000000000000000E+02 2.000000...

5.00000000000000000E+02 6.00000000000000000E+02 7.000000...
Eta= 7 0.00000000000000000E+00 1.00000000000000000E+02 2.000000...

5.00000000000000000E+02 6.00000000000000000E+02 7.000000...
Eta= 1 1.00000000000000000E+02 1.00000000000000000E+02 1.000000...

1.00000000000000000E+02 1.00000000000000000E+02 1.000000...
Eta= 2 2.00000000000000000E+02 2.00000000000000000E+02 2.000000...

2.00000000000000000E+02 2.00000000000000000E+02 2.000000...
Eta= 3 3.00000000000000000E+02 3.00000000000000000E+02 3.000000...

3.00000000000000000E+02 3.00000000000000000E+02 3.000000...
Eta= 4 4.00000000000000000E+02 4.00000000000000000E+02 4.000000...

4.00000000000000000E+02 4.00000000000000000E+02 4.000000...
Eta= 5 5.00000000000000000E+02 5.00000000000000000E+02 5.000000...

5.00000000000000000E+02 5.00000000000000000E+02 5.000000...
Eta= 6 6.00000000000000000E+02 6.00000000000000000E+02 6.000000...

6.00000000000000000E+02 6.00000000000000000E+02 6.000000...
Eta= 7 7.00000000000000000E+02 7.00000000000000000E+02 7.000000...

7.00000000000000000E+02 7.00000000000000000E+02 7.000000...

A.6 Computational grid enclosure

The computational grid enclosure file need to be specified, the file is generated by RGFGRID,
see RGFGRID UM (2016).

File contents The indices of the external computational grid enclosure(s) and op-
tionally one or more internal computational grid enclosures that out-
lines the active computational points in a Delft3D-FLOW computa-
tion. The file is strongly related to the curvilinear grid file.

Filetype ASCII
File format Free formatted
Filename <name.enc>
Generated RGFGRID

Record description:

Record Record description

All One pair of M and N indices representing the grid co-ordinates
where a line segment of the computational grid enclosure (polygon)
changes direction.

Restrictions:
⋄ A polygon must be closed. The first point of the polygon is repeated as last point.
⋄ A line segment may not intersect or touch any other line segment.
⋄ The angle formed by consecutive line segments (measured counter clock-wise) can

have a value of: 45, 90, 135, 225, 270 or 315 degrees, but not 0, 180 and 360 degrees.
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Legend:

+ water level point
| v-velocity point
− u-velocity point
Full thick line grid enclosure and (for the external polygon only) loca-

tion of water level open boundaries.
Full thin line location for velocity or discharge open boundaries.

Figure A.1: Example of computational grid enclosures

⋄ In a row or column there should be at least two active computational grid cells.
⋄ Input items in a record are separated by one or more blanks.

Example:

Model area with (one) external and one internal polygon, see Figure A.1.

1 1 begin external polygon
6 1
8 3
9 3
9 1

16 1
19 4
19 6
17 8
4 8
1 5
1 1 end external polygon

13 4 begin internal polygon
14 4
14 5
13 5
13 4 end internal polygon

A.7 Bathymetry file
File contents The bathymetry in the model area, represented by depth values (in

metres) for all grid points.
Filetype ASCII
File format Free formatted or unformatted
Filename <name.dep>
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Generated FLOW-GUI (only for uniform depth values).
Offline with QUICKIN and data from digitised charts or GIS-database.

Record description:

Filetype Record description

Free formatted Depth values per row, starting at N = 1 to N = Nmax, separated
by one or more blanks. The number of continuation lines is deter-
mined by the number of grid points per row (Mmax) and the maxi-
mum record size of 132.

Unformatted Mmax depth values per row for N = 1 to N = Nmax.

Restrictions:
⋄ The file contains one M and N line more than the grid dimension.
⋄ The maximum record length in the free formatted file is 132.
⋄ Depth values from the file will not be checked against their domain.
⋄ The input items are separated by one or more blanks (free formatted file only).
⋄ The default missing value is: −999.0

Example:

File containing 16 ∗ 8 data values for a model area with 15 ∗ 7 grid points (free formatted file).

1.0 2.0 3.0 4.0 -5.0 -5.0 -5.0 8.0 9.0 10.0 11.0
12.0 13.0 14.0 -5.0 -999.0
3.0 4.0 5.0 6.0 7.0 -6.0 -6.0 10.0 11.0 12.0 13.0

14.0 15.0 16.0 17.0 -999.0
5.0 6.0 7.0 8.0 9.0 10.0 -7.0 12.0 13.0 14.0 15.0

16.0 17.0 18.0 19.0 -999.0
7.0 8.0 9.0 10.0 11.0 12.0 13.0 14.0 15.0 16.0 17.0

18.0 19.0 -7.0 19.0 -999.0
9.0 10.0 11.0 12.0 13.0 14.0 15.0 16.0 17.0 18.0 19.0

20.0 19.0 18.0 17.0 -999.0
-7.0 12.0 13.0 14.0 15.0 16.0 17.0 18.0 19.0 20.0 19.0
18.0 17.0 16.0 15.0 -999.0
-8.0 -8.0 15.0 16.0 17.0 18.0 19.0 20.0 19.0 18.0 17.0
16.0 15.0 14.0 13.0 -999.0

-999.0 -999.0 -999.0 -999.0 -999.0 -999.0 -999.0 -999.0 -999.0 -999.0 -999.0
-999.0 -999.0 -999.0 -999.0 -999.0

A.8 Open boundaries file
File contents The location and description of open boundaries.
Filetype ASCII
File format Fix formatted for text variables; free formatted for real and integer

values.
Filename <name.bnd>
Generated FLOW-GUI

Record description:
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Record Record description

each record Name of the open boundary section (20 characters).
Type of boundary (1 character).

Z water level
C current
N Neumann
Q discharge per grid cell
T total discharge for boundary section
R Riemann

Type of data (1 character).

A astronomic
H harmonic
Q QH tables (only for water level boundaries)
T time-series

Grid indices of the begin and end point of the boundary section (4
integers).
Reflection coefficient (1 real), not for Neumann or Riemann.

Vertical profile (three strings); only for 3D simulations and velocity
type boundaries (C, Q, T and R).

Uniform
Logarithmic
3D profile

Two labels (each 12 characters, no blanks in the label name) refer-
encing to the blocks in the amplitude and phase file <∗.bca>; only
if the type of data is A.

Restrictions:
⋄ Maximum record length in the free formatted file is 132.
⋄ The boundary section name must start at position one in a record.
⋄ The value of the reflection coefficient will not be checked on its domain.
⋄ All input items in a record must be separated by one or more blanks.
⋄ Astronomic and harmonic forced boundaries must be specified before QH-relation forced

boundaries, which in turn should be specified before time-series forced boundaries.
⋄ Astronomic and harmonic forced boundaries cannot be combined.

Example:

Two boundary sections with data type A(stronomic) and one with type T(ime series).

Paradise Bay 1 Q A 1 1 1 5 0.0 Uniform Paradise_1A Paradisee_lB
Paradise Bay 2 C A 16 3 16 6 0.0 Logarithmic Paradise_2A Paradisee_2B
Sea Entrance Z T 4 8 14 8 0.0

Remarks:
⋄ A label may not contain blanks between non-blank characters.
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⋄ For the labels 12 characters are read. Be sure the second label starts at least 13
positions after the start of the first.

A.9 Cut out area information file
File contents Names of the files defining the cut out area by a polygon, open

boundaries and aggregation.
Filetype ASCII
File format Fix formatted for text variables, free formatted for real and integer

values.
Filename <name.cai>
Generated D-Waq DIDO, or manually offline

Record description:

Keyword Description

FileInformation

FileCreatedBy D-Waq DIDO version number

FileCreationDate creation date and time

FileVersion version number of <∗.cai> file

General

Subject Cut out areas

PolygonFile Name of the polygon file defining the cut out area

PolylineFile Name of the polyline file defining the open boundaries of the cut out
area. If a part of the open boundary defined by the cut out area is
the same as the open boundary of the complete model that part is
not listed in the polyline file.

Aggregation Name of the file containing the grid cell aggregation.

Restriction:
⋄ The maximum record length in the file is 132.

Example:

The number of observation areas is 3. They are called ‘ObsArea 001’, ‘ObsArea 002’ and
’ObsArea 003’.

[FileInformation]
FileGeneratedBy = Deltares, D-Water_Quality_DIDO Version 5.02.00.51361 (Win64), Jun 26 2017, 11:12:25
FileCreationDate = 2017-06-26, 14:30:36
FileVersion = 0.01

[General]
Subject = Cut Out Areas
PolygonFile = manukau_harbour.pol
OpenBoundary = manukau_harbour.pli
Aggregation = manukau_harbour.dwq

Deltares 71 of 87



DRAF
T

D-Waq DIDO, User Manual

Example polygon file:

See section A.4 for definition of the file.

*
* Deltares, D-Water_Quality_DIDO Version 5.02.00.51361 (Win64), Jun 26 2017, 11:12:25

* File creation date: 2017-06-26, 14:30:36

*
* Coordinate System = Cartesian

*
L000001
8 2
1.7359385E+06 5.9032137E+06
1.7391717E+06 5.8960905E+06
1.7509428E+06 5.8752258E+06
...
1.7757480E+06 5.9113979E+06
1.7448299E+06 5.9144796E+06
1.7359385E+06 5.9032137E+06

Example polyline file:

See section A.3 for definition of the file.

*
* Deltares, D-Water_Quality_DIDO Version 5.02.00.51361 (Win64), Jun 26 2017, 11:12:25

* File creation date: 2017-06-26, 14:30:36

*
* Coordinate System = Cartesian

*
L00001
19 2
1.7369436E+06 5.9009168E+06
1.7372404E+06 5.9006817E+06
1.7372765E+06 5.9005282E+06
...
1.7379355E+06 5.8991023E+06
1.7379482E+06 5.8990088E+06
1.7379587E+06 5.8989165E+06

Example dwq-file:

See section A.2 for definition and example of the file.

A.10 Observation area information file
File contents Name of the polygon with observation areas.
Filetype ASCII
File format Fix formatted for text variables, free formatted for real and integer

values.
Filename <name.oai>
Generated D-Waq DIDO, or manually offline

Record description:

A header block containing information about versions, and the name of the polygon file.

For each observation area the details.
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Keyword Description

FileInformation

FileCreatedBy D-Waq DIDO version number

FileCreationDate creation date and time

FileVersion version number of <∗.oai> file

General

Subject observation areas

PolygonFile name of polygon file with polylines defining observation areas

ObservationArea

Name name of the observation area (blockname in polygon file)

Restriction:
⋄ The maximum record length in the file is 132.

Example:

The number of observation areas is 3. They are called ‘ObsArea 001’, ‘ObsArea 002’ and
’ObsArea 003’.

[FileInformation]
FileGeneratedBy = Deltares, Delft3D-DIDO Version 3.39.01.4423:4459, Sep 25 2008, 20:10:54
FileCreationDate = 2008-09-25, 22:11:08
FileVersion = 0.01

[General]
Subject = Observation areas
PolygonFile = friesche_zeegat.pol

[ObservationArea]
Name = ObsArea 001

[ObservationArea]
Name = ObsArea 002

[ObservationArea]
Name = ObsArea 003

Example polygon file:

*
* WL | Delft Hydraulics, Delft3D-DIDO

* 22:57:01, 30-07-2008

*
ObsArea 001

5 2
1.8768018E+05 6.1708738E+05
1.8996981E+05 6.1001035E+05
1.9746314E+05 6.1266423E+05
1.9480925E+05 6.1838830E+05
1.8768018E+05 6.1708738E+05

ObsArea 002
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5 2
2.0011703E+05 6.1818015E+05
1.9819166E+05 6.1063479E+05
2.0568498E+05 6.0870942E+05
2.0797461E+05 6.1599460E+05
2.0011703E+05 6.1818015E+05

ObsArea 003
5 2

1.9340425E+05 6.1396516E+05
2.0183425E+05 6.1365294E+05
1.9944054E+05 6.0558720E+05
1.9522555E+05 6.0595146E+05
1.9340425E+05 6.1396516E+05

A.11 Data monitoring file
File contents Volume numbers for each observation area.
Filetype ASCII
File format Free formatted.
Filename <name.dmo>
Generated D-Waq DIDO, or manually offline

Record description:

A header block containing information about versions, and the name of the polygon file.

For each observation area the details.

Record Record Description

1 Number of observation areas

2 Observation area name and number of segments belonging to this
observation area

NVOL integers indicating the volumes belonging to the observation
area

Restriction:
⋄ The maximum record length in the file is 132.

Remark:
⋄ If using an existing polygon file (including one or more polygons), modifying the value of

the keyword PolygonFile in the <oai>-file, then load the<oai>-file in the D-Waq
DIDO and reuse the existing polygons.

Example:

The number of observation areas is 3. They are called ‘Observation Area 001’, ‘Observation
Area 002’ and ’Observation Area 003’.

3
'Monitoring Area 001' 22

80 102 124 146 59
81 103 125 147 60
82 104 126 148 61
83 105 127 149 84
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106 128
'Monitoring Area 002' 37

275 297 210 232 254
276 298 189 211 233
255 277 299 212 234
256 278 300 213 235
257 279 301 214 236
258 280 302 215 237
259 281 303 260 282
304 283

'Monitoring Area 003' 33
163 98 120 142 164
186 99 121 143 165
187 209 100 122 144
166 188 210 232 101
123 145 167 189 211
233 102 124 146 168
190 212 234

A.12 DD Boundary file
File contents Domain decomposition boundaries connecting two grids for the pre-

scribed indices.
Filetype ASCII
File format Fix formatted.
Filename <name.ddb>
Generated RGFGRID, or manually offline

Record description:

Record Record Description

N Name of the first grid, followed by four integers indicating the gridline
on which the boundary lies, followed by the name of the second grid
and four integers indicating the gridline on which the boundary lies.

Restrictions:
⋄ No space allowed in grid filename.
⋄ The maximum record length in the file is 132.

Example:

In the following example 4 sub-domains exist. Domain d01_ns is coupled to oa1_ns, ob1_ns
and oc1_ns. Furthermore oa1_ns is coupled to ob1_ns, and ob1_ns to oc1_ns.

d01_ns.grd 5 16 5 1 oa1_ns.grd 28 35 28 20
d01_ns.grd 245 1 5 1 ob1_ns.grd 17 21 1 21
d01_ns.grd 245 52 245 1 oc1_ns.grd 1 44 1 27
ob1_ns.grd 1 4 1 21 oa1_ns.grd 28 3 28 20
ob1_ns.grd 17 4 17 21 oc1_ns.grd 1 10 1 27

A.13 Dry points file
File contents Index location of (permanently) dry points.
Filetype ASCII
File format Free formatted
Filename <name.dry>
Generated QUICKIN or FLOW-GUI
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Figure A.2: Dry points in model area

Record description:

Record Record description

each record The grid indices of the begin and end point of a dry section (4 inte-
gers).

Restrictions:
⋄ The angle of a line of dry points and the horizontal numerical grid axis can be an integer

multiple of 45 degrees.
⋄ Dry points may not be defined along the model boundaries (which by default lie along

the lines M = 1, N = 1, M = Mmax or N = Nmax). Therefore, the indices of these points
must lie between M = 2 and Mmax-1 and N = 2 and Nmax-1, respectively.

⋄ The input items are separated by one or more blanks.
⋄ The most lower-left dry point has indices (2, 2).

Example:

Five sets of dry points in a model area of 19 ∗ 8 grid points, see Figure A.2.

5 3 5 6
8 4 10 6

13 3 14 3
13 4 14 4
14 6 14 6
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Figure A.3: Example of thin dams in a model area

A.14 Thin dams file
File contents Location and type of thin dams.
Filetype ASCII
File format Free formatted
Filename <name.thd>
Generated QUICKIN or FLOW-GUI

Record description:

Record Record description

each record The grid indices of the begin and end point of a line of thin dams (4
integers). A character indicating the type of thin dams (U or V).

Restrictions:
⋄ The angle of the line segment and the horizontal numerical grid axis may be an integer

multiple of 45 degrees.
⋄ Thin dams can not be defined along the model boundaries (which by default lie along

the lines M = 1, N = 1, M = Mmax or N = Nmax). Therefore, the indices of thin dams
must lie between M = 2 and Mmax-1 and N = 2 and Nmax-1 respectively.

⋄ Input items are separated by one or more blanks.
⋄ The direction of the dam is perpendicular to the velocity direction over which the dams

are superimposed!

Example:

Three (sets of) thin dams in model area of 19 ∗ 8 grid points, see Figure A.3.

6 2 6 4 V
7 4 10 7 U

12 3 12 7 U

A.15 Colour scheme file
File contents The colour scheme
Filetype ASCII
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File format Free formatted
Filename <name.clr> or <name.clrmap>
Generated manually

Record description:

Record Record description

1 COLORMAP

2 NAME=name

3 SPACE=RGB, RGB is the only allowed space for this program

4 – N one real and three integers.

The first column represent the relative distribution of the defined colours in column 2–4 (rep-
resenting the RGB values).

Example:

COLORMAP
NAME=copper
SPACE=RGB
0.0000 0 0 0
0.8000 255 159 101
1.0000 255 199 127

A.16 Settings file
File contents Settings of the program
Filetype ASCII
File format Fix formatted
Filename <name.ini>
Generated By the program

Record description:
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Record Record description

FileInformation

FileCreatedBy D-Waq DIDO version number

FileCreationDate creation date and time

FileVersion version number of <∗.ini> file

DIDOParameter

name integer value

Colours

name RGB value (3 integers)

line width

dots sizes

Example:

[FileInformation]
FileGeneratedBy = Deltares, Delft3D-DIDO Version 4.04.00.11845:11904M, Jun 27 2010, 18:36:38
FileCreationDate = 2010-06-28, 09:30:32
FileVersion = 0.02

[DIDOParameter]
AutoscaleLegend = 1
XCoorLegend = 16
YCoorLegend = 20
StayOnStartupDirectory = 0
CellsToAggregate = 3
DeeperAggregation = 1.00000000000000002E+30

[Colours]
ColourBackground = 255 255 210
LegendColourBackground = 255 255 255
lineColourLandBoundary = 132 066 000
lineColourPolygon = 170 000 127
lineColourActiveGrid = 128 128 128
lineColourMarkVolume = 000 128 128
lineColourActiveVolume = 000 000 255
lineColourActiveCmpBnd = 005 005 005
lineColourActiveOpenBnd = 000 000 255
lineColourActiveDDBnd = 176 000 255
lineColourGrid = 192 192 192
lineColourVolume = 128 128 128
lineColourCmpBnd = 050 050 050
lineColourOpenBnd = 000 000 150
lineColourDDBnd = 176 000 255
pointColourVolumeCentre = 160 160 160
lineColourObsPolygon = 005 005 005
DryPoints = 000 000 000
ThinDams = 005 005 005

[Width]
lineWidthLandBoundary = 1
lineWidthPolygon = 1
lineWidthActiveGrid = 1
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lineWidthMarkVolume = 3
lineWidthActiveVolume = 1
lineWidthActiveCmpBnd = 1
lineWidthActiveOpenBnd = 3
lineWidthActiveDDBnd = 3
lineWidthGrid = 1
lineWidthVolume = 1
lineWidthCmpBnd = 1
lineWidthOpenBnd = 5
lineWidthDDBnd = 3
pointSizeVolumeCentre = 1
lineWidthThinDams = 3
lineWidthObsPolygon = 1

[Caches]
inactdepth = 5
actdepth = 5
centre = 5
inactgrid = 4
actgrid = 4
inactvolumes = 3
actvolumes = 2
boundary = 1
landboundary = 1
obs_areas = 2
polygons = 0
drythdobs = 1
rest = 1
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B.1 Introduction

The requirements with regards to the horizontal and vertical resolution of the computational
grid for water quality calculations do not always coincide with the requirements for hydro-
dynamic modelling. Quite often it is necessary for a hydrodynamic model to have a high
horizontal and vertical resolution, whereas the gradients in the water quality parameters are
much "lazier". Using a large number of vertical layers then becomes a computational burden.
The same is true for very detailed grids needed to resolve the bottom topography.

The net result is that it is often beneficial to aggregate the grid and the hydrodynamic results
that based on the grid before running a water quality model. This is the purpose of the Agrhyd
program. Horizontal aggregation is in general prepared via the D-Waq DIDO program, as this
allows you define the aggregation using a graphical user-interface. Vertical aggregation is
prepared using a simple text file.

Currently, Agrhyd is capable of processing Delft3D-FLOW and D-Flow FM hydrodynamic data
sets. Data sets that produce the hydrodynamic data set in the same formats might also be
processed, however, this has not yet been tested.

In addition the Agrhyd program is capable of concatenating various hydrodynamic databases
that are based on the same grid from Delft3D-FLOW runs that were restarted (keyword in-
puthydpatch,inputhydpatch1, inputhydpatch2, etc).

B.2 Input parameters

The program takes as an argument the name of the input file (formatted as a so-called INI-file).
The keywords need to appear below the "chapter" "[General]".

Here is an example:

[General]
inputhyd = com-test.hyd
output = com-test2
vertical_aggregation_file = from_25_to_10layers.inp

Notes:

⋄ The program supports both structured curvilinear grids (such as provided by Delft3D-
FLOW) and unstructured grids (as from D-Flow FM), but regular aggregation and expan-
sion are only possible for structured grids.

⋄ If you specify a file for horizontal aggregation, then you cannot also specify regular aggre-
gation.

⋄ Concatenation of hydrodynamic databases requires that they are based on the same hy-
drodynamic grid and if aggregation has been applied within the hydrodynamic calculation,
then the aggregation specification must be the same for all.
This is checked only rudimentary, so you may have to be careful.
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Table B.1: Keywords in the input file for agrhyd.

Keyword Purpose Default

File names

inputhyd Name of the hyd-file (input) required

inputhydpatch Name of an additional hyd-file (input) optional

inputhydpatch1 Name of a second additional hyd-file (input) optional

inputhydpatch2 Ditto, these hydrodynamic results are appended optional

... to the very first result (see text below) optional

inputhydpatch9 Name of a ninth additional hyd-file (input) optional

horizontal_aggregation_file Name of an aggregation file (.dwq) optional

vertical_aggregation_file Name of a file to aggregate layers optional

output Name for the output files required

Regular aggregation

expand Expand the grid (disaggregate) false

regular Whether regular aggregation is defined here false

(for structured curvilinear grids only)

m_fact Number of cells taken together in first (m) direction –

n_fact Number of cells taken together in second (n) direction –

m_offset Offset for starting aggregation in first (m) direction –

n_offset Offset for starting aggregation in second (n) direction –

Other parameters

lenlen Do not recalculate the dispersion length false

minimum-dispersion-length Minimum length for dispersion 0.0 m

start Start time for output (default to start of files) –

stop Stop time for output (default to end of files) –

reference_time_output New reference time (calendar date/time) –

The vertical aggregation, i.e. taking layers together is specified via a simple file, containing
on the first line the number of layers in the hydrodynamic model and on subsequent lines the
indices of the water quality layer for each hydrodynamic layer. For instance:

10 (Number of layers in the hydrodynamic model)
1 1 1 2 2 2 3 3 3 3

This example states that the first three layers in the hydrodynamic model should be put into
the first water quality layer, then the next three in the second water quality layer, and the final
four in the third water quality layer. You are yourself responsible for making sure that the layer
numbering is consistent.
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B.3 Output files

The program will write a number of output files:

⋄ A new hyd-file, which contains the names of the new files, resulting from the aggregation
and concatenation of the original hydrodynamic files.

⋄ A report file with suffix "-agrhyd.rep"
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